System Requirements

To use the I-CARE system as a student, faculty member or administrator, all that is required for most courses is a PC, Macintosh or Unix computer with a compatible, Java enabled Web browser. Below is a list of all the browsers that have been tested by the developers and information as to which are compatible with the system. We recommend that, if you are currently using one of the incompatible browsers and wish to use the I-CARE system, that you acquire and install one of the compatible browsers listed below.

 A list of other software programs that may be required for some specific courses follows the list of browsers.

The developers would appreciate information you may have about the compatibility of other browsers not listed. If you are using another compatible or incompatible browser not listed below, please fill out the form at the bottom of this page.

For information concerning installation of the I-CARE system, please refer to the I-CARE Installation Guide which is also available in the I-CARE User Manual.

Client PC: 486 Multimedia Computer or better with minimum 8 MB of memory. It is our recommendation to use at lease Pentium PC with 16 MB of memory for some tools in I-CARE system. You may also use a Macintosh or Unix computer(except I-Phone tool) with suitable Java enabled browser.
 
 
Browser Computer System Compatibility
AOL 1.0-3.0 
Note: 
You can still use Netscape or Internet Explorer 
to access I-CARE through AOL
All Incompatible
Netscape Navigator Gold 3.03 
Note: 
Chat feature does not work
Windows 3.1 Partially Compatible
Netscape Navigator Gold 3.01 Windows 95 Compatible
Netscape Navigator Gold 3.01 Windows NT Compatible
Netscape Navigator Gold 3.01 Macintosh Compatible
Netscape Navigator Gold 3.0 Windows NT Compatible
Netscape Communicator 4.0-4.04-4.51 Windows NT Compatible
Netscape Communicator 4.0-4.04-4.51 Windows 95 Compatible
Netscape Communicator 4.0 Macintosh Compatible
Netscape Navigator Gold 3.01 Linux Compatible
Netscape Navigator 2.01 
Note: 
Chat might not work. 
I-Phone might not work 
Some spurious error messages 
might be generated.
Sun Solaris 2.5 Partially Compatible
Netscape Navigator 2.02 
Note: 
I-Phone might not work
Windows 95 Compatible
Netscape Navigator Gold 3.01 Sun Solaris 2.5 Compatible
Internet Explorer 2.0 
Note:
I-Phone might not work
Windows NT Incompatible
Internet Explorer 3.0 Windows NT Compatible
Internet Explorer 3.0 Windows NT Compatible
Internet Explorer 4.0 - 5.0 Windows NT Compatible
Internet Explorer 3.02 Window 95 Incompatible
Internet Explorer 4.0 - 5.0 Window 95 - 98 Compatible
Lynx all versions Unix Incompatible

Other programs required for selected courses:

Note1: I-CARE allows the development of course materials in HTML containing images and equations in LaTeX, however, there are many other file formats for displaying course materials that may be used by some faculty's courses. The following programs may be needed to view their corresponding files.

The Postscript File Viewer
Available at the following site: http://www.cs.wisc.edu/~ghost/aladdin/get510.html
To install the viewer on your computer, download the following:
gs510ini.zip, configuration, initialization, and example files, 805k
gs510w32.zip, MS-Windows 32-bit (Win32s, Win95, WinNT), 556k
gs510fn1.zip, Ghostscript standard fonts, 1143k
Unzip them into a temportary directory and run setup. After the installation, you should then set up your browser to use it as a helper application.

 Adobe Acrobat Reader
Acroread 3.0 is available at:http://www.adobe.com/prodindex/acrobat/readstep.html

Microsoft Word 7.0
Note that Microsoft Word is not backward compatible. For example, you won’t be able read Microsoft Word 7.0 document from Microsoft Word 6.0 application.
 
 

Note2: The I-Phone in I-CARE system is based on microsoft NetMeeting. Before you use this tool,  The following programs may be needed .

The Microsoft NetMeeting
Available at the following site: http://www.microsoft.com/msdownload/ieplatform/netmeeting/netmeeting.htm

 Windows-Compatible sound card full-duplex driver
Available at I-CARE Internet Telephony system requirement page.

More informations about I-Phone tool can be available at the Internet Telephony system requirement page.


Please sent information about I-CARE (problems) below:

Your name:
E-Mail Address:
 
Please use this space to submit information about the compatibility of browsers not listed.

Return to I-CARE